Jet tasks hangs frequently


#1

Firstly, jet / docker platform is awesome! I love the simplicity and power. No other CI platform comes close (I used them all today). So, thanks.

I’m finding jet steps hangs quite often and not itself exiting when the underlying commands end. Specifically it’s usually running command steps involving running node / npm scripts (under docker of course).

When the jet process is hanging, ctrl-c does nothing. There is no docker container left running. There is no extraneous jet process running (apart from the seemingly-ever-running jet background processes).

caveat: I’m running docker for mac beta locally (which is mostly solid)

Is there a known issue around this, or some other steps to diagnose?


#2

We are also seeing this issue when using the mac beta of Docker for Mac.

We are however also observing it on docker-machine albeit less often.


#3

We are also seeing this. Started about 5 weeks ago. I opened a support ticket, but they weren’t able to reproduce. Though I didn’t like the solution I stopped using Jet locally as it was working on Codeship without issue.

However as of yesterday afternoon it stopped working on Codeship as well. It’ll run for 120 minutes and time out saying no log information was sent in X-time. However if you look at the log, just like when you run using Jet. The process has completed successfully.

Another interesting fact was if you do a docker ps -a and look for jet, you’ll notice that the step completed successfully with an exit code of zero.

Seems like it could be a combination of npm + codeship exit code trapping.


#4

Yeah Adam that mirrors our findings with NPM exactly.


#5

We’re using Node v6.2.0 and NPM v3.9.3.

We’re also on the Docker Beta for Mac. We switched back to docker toolbox and for a short period that still worked, but as you said it ended up having issues too.

What version of Node / NPM are you using? Do you use the Node Docker image as your base?

-Adam


#6

Hey, all-

I wanted to jump in and provide a bit of clarity.

We are currently hard at work on Compose V2 support, which involves major changes to our Jet binary to make it more Docker-native and to bring it to full parity with Compose itself.

We think the problem you’re seeing is a bug specific to one or multiple Docker for Mac versions, although so far it’s not replicated on our end. However, because of the foundational work on Jet being done now and estimated for release potentially as soon as the next couple of months, the best advice would be to work around it because this is exactly the type of error we should no longer be at risk of once we get to full Compose parity.


#7

Ethan Jones is there any workaround at the moment? I tried putting the whole command inside of a bash -c “” and that seems to resolve it, but didn’t run it often enough to fully rule out that this solves the issue


#8

We’re also experiencing this issue with the first step in our codeship-steps taking a substantial amount of time to complete even though the logs indicate it should have exited already. This command is sometimes a npm run or even a simple cp.

Was there a solution to this problem? I’m experiencing this on the new ‘pro’ platform. node:6.9.2